Server Requirements for Getsy

Server Requirements for Getsy

Getsy 2.0 Server Requirements

Please note that the settings below are the recommended minimum for the script to run trouble-free. Most major hosting providers will be able to offer you a plan with these requirements. Hosting companies using cPanel are recommended!

What you need:

  • Linux Server
  • Mysqli PHP extension
  • Apache or NGINX Web Server
  • PHP 5.6 with multibyte string, ZIP archive support
  • PDO sqlite, mysql, mysqli
  • MySQL version 5.5 or above (5.6 recommended for fulltext search)
  • MySQL InnoDB Database Engine
  • Zend Guard Loader with PHP 5.6 support (required for all license types)
  • GD2 Library or higher
  • exif PHP extension (responsible for image processing, including on Mobile)
  • Apache mod_rewrite enabled
  • Enabled PHP5 - curl ssl
  • Enabled Zlib extension
  • Register Globals OFF
  • Enabled PHP functions - fopen, fclose, fwrite
  • Minimum memory limit of 512MB for smooth operation

In addition you need the following if you are going to use the Chat module:

Node.js - v. 0.10.33 or higher.

MongoDB - db version v. 2.0.4 or above.

pdfile version 4.5 or higher.

To check the compatibility of your hosting account please DOWNLOAD THE FILE, extract it from the archive, and upload it to the public_html folder of your server. Access the file by typing the following address: http://mydomain.com/testmyserver.php where mydomain.com is the domain name you intend to have your Getsy site on

 

Getsy 1.5 Server Requirements

Please note that the settings below are the recommended minimum for the script to run trouble-free. Most major hosting providers will be able to offer you a plan with these requirements. Hosting companies uing cPanel are recommended!

What you need:

  • Linux Server
  • Apache or NGINX Web Server
  • At least 50 Megabytes of disk space for the script files. You will need  additional space for user avatars, shop cover photos, item images, etc.
  • MySQL version 5.5
  • PHP 5.4 with multibyte string and ZIP archive support, PDO and Mysqli
  • Zend Guard with PHP 5.4 support
  • GD2 Library or higher
  • Apache mod_rewrite
  • Enabled PHP5 - curl ssl
  • Enabled Zlib extension
  • Register globals OFF
  • Enabled PHP functions - fopen, fclose, fwrite
  • Minimum memory limit of 512MB

To check the compatibility of your hosting account please DOWNLOAD THE FILE, extract it from the archive, and upload it to the public_html folder of your server. Access the file by typing the following address: http://mydomain.com/testmyserver.php where mydomain.com is the domain name you intend to have your Getsy site on

To Top